注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

ideality

@linux c 编程@

 
 
 

日志

 
 
 
 

eclipse中出现The import com.opensymphony cannot be resolved的解决办法  

2011-02-22 16:51:26|  分类: java |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

因为用的是最新的版本:即导入的jar包有:commons-logging-1.0.4.jar、ognl-2.6.11.jar、struts2-core-2.2.1.1.jar、xwork-2.2.1.1.jar等,在使用ActionContext()时,说cannot be resolved,后来引入import com.opensymphony.xwork2.ActionContext; 又报The import com.opensymphony cannot be resolved。其解决办法是:直接导入xwork-core-2.2.1.1.jar包就可以啦!

其导入步骤为:

右键点击工程-->properties-->Java Build Path-->Libraries-->Add External JARs ,选择你要导入的包;也可以新建个Library ,选择User  Library然后Add JARs ,让后将你的Library导入工程。

  评论这张
 
阅读(10320)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018